Jump to content

Anyone here a Ubuntu guru? (Or even half knowledgeable)


flying dog
 Share

Recommended Posts

Folks,

 

I am (was) running Ubuntu 17.x

 

Just recently it updated itself to 18.04.

 

I have some "scripts" (.sh) files that worked.

 

Now, when I run them, I get errors:

 

./foo.sh: /usr/share/bashdb/bashdb-main.inc: No such file or directory

 

./foo.sh: warning: cannot start debugger; debugging mode disabled

 

Ok, the script "works" but some don't. (Like remote mounting.)

 

I'm guessing it needs/wants the debugger.

 

I am stuffed if I can work out how to get/install debugger.

 

sudo apt install bashdb

 

Reading package lists... Done

 

Building dependency tree

 

Reading state information... Done

 

E: Unable to locate package bashdb

 

Help - please.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...